Шрифты в Debian Squeeze

Весьма избитая тема, конечно. Однако, в большинстве инструкций все упирается в давно просроченные ссылки, и найти один из патчей было не так-то просто.

Для того, чтобы не заниматься ручной настройкой шрифтов, не искать нужные настроечные файлы для /etc/fonts, будем патчить не только cairo, но и fontconfig. Разбираться, какие патчи для fontconfig из пакета ubuntu нужны, а какие нет — было лень, поэтому я использовал все.

Подготовка к сборке:
apt-get install dpkg-dev devscripts

Исходный код:
apt-get source libcairo2 fontconfig

Зависимости для сборки:
apt-get build-dep libcairo2 fontconfig

Далее необходимо стянуть патчи:
wget http://randoman.ru/files/squeeze-fonts/squeeze-fonts-patches.tar.gz
tar -zxf squeeze-fonts-patches.tar.gz

Накладываем патчи на cairo:
cd cairo-1.8.10
patch -p1 -i ../squeeze-fonts-patches/cairo/04_lcd_filter.patch
patch -p1 -i ../squeeze-fonts-patches/cairo/06_Xlib-Xcb-Hand-off-EXTEND_PAD-to-XRender.patch
patch -p1 -i ../squeeze-fonts-patches/cairo/cairo-respect-fontconfig.patch

Обновляем версию:
dch -i
Что-нибудь пишем после звездочки, сохраняем, выходим.

Собираем пакет:
dpkg-buildpackage

Накладываем патчи на fontconfig:
cd ../fontconfig-2.8.0/
patch -p1 -i ../squeeze-fonts-patches/fontconfig/00_old_diff_gz.patch
patch -p1 -i ../squeeze-fonts-patches/fontconfig/04_ubuntu_monospace_lcd_filter_conf.patch
patch -p1 -i ../squeeze-fonts-patches/fontconfig/05_lcdfilterlegacy.patch
patch -p1 -i ../squeeze-fonts-patches/fontconfig/05_ubuntu_add_hinting_and_antialiasing_confs.patch
patch -p1 -i ../squeeze-fonts-patches/fontconfig/06_ubuntu_lcddefault.patch
patch -p1 -i ../squeeze-fonts-patches/fontconfig/07_no_bitmaps.patch

Обновляем версию:
dch -i
Также что-нибудь пишем после звездочки, сохраняем, выходим.

Собираем пакет:
dpkg-buildpackage

Устанавливаем пакеты:
cd ..

Для 32-битных систем:
dpkg -i fontconfig_2.8.0-2.2_i386.deb fontconfig-config_2.8.0-2.2_all.deb libcairo2_1.8.10-6.1_i386.deb libfontconfig1_2.8.0-2.2_i386.deb

Для 64-битных систем:
dpkg -i fontconfig_2.8.0-2.2_amd64.deb fontconfig-config_2.8.0-2.2_all.deb libcairo2_1.8.10-6.1_amd64.deb libfontconfig1_2.8.0-2.2_amd64.deb

Если необходимо — установить dev пакеты.

После этого надо перезапустить иксы. Ну или просто перезагрузиться.

Добавить комментарий

Ваш e-mail не будет опубликован.

Можно использовать следующие HTML-теги и атрибуты: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>